const regex = /\<b[^<]*?\>([^\s<]+?)\<\/b\>\s*(?!\<br\>)/iug;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\<b[^<]*?\\>([^\\s<]+?)\\<\\\/b\\>\\s*(?!\\<br\\>)', 'iug')
const str = `should NOT match - ok
<b>word</b><br>
should match
<b>word</b> in text
half<b>word</b> `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}