import re
regex = re.compile(r"\<b[^<]*?\>([^\s<]+?)\<\/b\>\s*(?!\<br\>)", flags=re.IGNORECASE | re.UNICODE)
test_str = ("should NOT match - ok\n"
"<b>word</b><br>\n\n\n"
"should match\n"
"<b>word</b> in text\n"
"half<b>word</b> ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")