re = /\<b[^<]*?\>([^\s<]+?)\<\/b\>\s*(?!\<br\>)/i
str = 'should NOT match - ok
<b>word</b><br>
should match
<b>word</b> in text
half<b>word</b> '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end