import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<img[^>]*class=\\\"[^>]*\\bfoo\\b[^>]*\\\"[^>]*>)";
final String string = "<img src=\"\" class=\"foo\" />\n"
+ "<img src=\"\" class=\"foo bar\" />\n"
+ "<img src=\"\" class=\"baz foo bar\" />\n"
+ "<img src=\"\" class=\"dont match fool\" />";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}