re = /(<img[^>]*class=\"[^>]*\bfoo\b[^>]*\"[^>]*>)/i
str = '<img src="" class="foo" />
<img src="" class="foo bar" />
<img src="" class="baz foo bar" />
<img src="" class="dont match fool" />'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end