import re
regex = re.compile(r"(<img[^>]*class=\"[^>]*\bfoo\b[^>]*\"[^>]*>)", flags=re.IGNORECASE)
test_str = ("<img src=\"\" class=\"foo\" />\n"
"<img src=\"\" class=\"foo bar\" />\n"
"<img src=\"\" class=\"baz foo bar\" />\n"
"<img src=\"\" class=\"dont match fool\" />")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")