$re = '/(<img[^>]*class=\"[^>]*\bfoo\b[^>]*\"[^>]*>)/i';
$str = '<img src="" class="foo" />
<img src="" class="foo bar" />
<img src="" class="baz foo bar" />
<img src="" class="dont match fool" />';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);