package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)w(?:e{2})?k\s*(\d+)(?: +(\d{4})\b)?(?:(?:\s*(?:until|tm)\s*|[ _\/])(?:w(?:e{2})?k)?(\d+)(?: +(\d{4})\b)?)?`)
var str = `wk 1 2016 // w eek 1 (2016)
(wk 47 2015 tm 9 2016) // w eek 47 (2015) - w eek 9 (2016)
Soccer International wk43
National Geopgraphic (wk50)
Schoolpaper wk39/wk43
Some magazine week12 until 16
Another magazine wk36_38
Another magazine wk36_wk38`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}