use strict;
my $str = 'wk 1 2016 // w eek 1 (2016)
(wk 47 2015 tm 9 2016) // w eek 47 (2015) - w eek 9 (2016)
Soccer International wk43
National Geopgraphic (wk50)
Schoolpaper wk39/wk43
Some magazine week12 until 16
Another magazine wk36_38
Another magazine wk36_wk38';
my $regex = qr/(?i)w(?:e{2})?k\s*(\d+)(?: +(\d{4})\b)?(?:(?:\s*(?:until|tm)\s*|[ _\/])(?:w(?:e{2})?k)?(\d+)(?: +(\d{4})\b)?)?/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}