import Foundation
let pattern = #"(?i)w(?:e{2})?k\s*(\d+)(?: +(\d{4})\b)?(?:(?:\s*(?:until|tm)\s*|[ _\/])(?:w(?:e{2})?k)?(\d+)(?: +(\d{4})\b)?)?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
wk 1 2016 // w eek 1 (2016)
(wk 47 2015 tm 9 2016) // w eek 47 (2015) - w eek 9 (2016)
Soccer International wk43
National Geopgraphic (wk50)
Schoolpaper wk39/wk43
Some magazine week12 until 16
Another magazine wk36_38
Another magazine wk36_wk38
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)