using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"return[ \t]+(""[^""\\]*(?:\\.[^""\\]*)*""|@""[^""]*(?:""[^""]*)*""|[^""\n;]*);?";
string substitution = @"{\g<0>}";
string input = @"return @""hello world""";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}