// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"return[ \t]+("[^"\\]*(?:\\.[^"\\]*)*"|@"[^"]*(?:""[^"]*)*"|[^"\n;]*);?"#).unwrap();
let string = "return @\"hello world\"";
let substitution = "{\\g<0>}";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}