use strict;
my $str = 'return @"hello world"';
my $regex = qr/return[ \t]+("[^"\\]*(?:\\.[^"\\]*)*"|@"[^"]*(?:""[^"]*)*"|[^"\n;]*);?/p;
my $subst = '{\\g<0>}';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";