using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:https:\/\/)*discord\.(?:(?:com\/gifts\/)|(?:gift)).*";
string input = @"https://discord.gift/vtddsnVcStAp664sByFsjTT
discord.com/gifts/J6v7WbpUNGqtQdsUsfhCrXxj";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}