package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(?:https:\/\/)*discord\.(?:(?:com\/gifts\/)|(?:gift)).*`)
var str = `https://discord.gift/vtddsnVcStAp664sByFsjTT
discord.com/gifts/J6v7WbpUNGqtQdsUsfhCrXxj`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}