re = /(?:https:\/\/)*discord\.(?:(?:com\/gifts\/)|(?:gift)).*/mi
str = 'https://discord.gift/vtddsnVcStAp664sByFsjTT
discord.com/gifts/J6v7WbpUNGqtQdsUsfhCrXxj'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end