$re = '/(?:https:\/\/)*discord\.(?:(?:com\/gifts\/)|(?:gift)).*/mi';
$str = 'https://discord.gift/vtddsnVcStAp664sByFsjTT
discord.com/gifts/J6v7WbpUNGqtQdsUsfhCrXxj';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);