# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/("(?=((?:[^"\\]+|\\[\s\S])*))\2"|'(?=((?:[^'\\]+|\\[\s\S])*))\3')|\/\/.*|\/\*(?=((?:[^*]+|\*(?!\/))*))\4\*\//\1/g;t' <<< "/*My function
is great.*/
int j = 0//hello world
void foo(){
//tricky example
cout << \"This // is // not a comment\n\";
}"