#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "("(?=((?:[^"\\]+|\\[\s\S])*))\2"|'(?=((?:[^'\\]+|\\[\s\S])*))\3')|//.*|/\*(?=((?:[^*]+|\*(?!/))*))\4\*/"
Local $sString = "/*My function" & @CRLF & _
"is great.*/" & @CRLF & _
"int j = 0//hello world" & @CRLF & _
"void foo(){" & @CRLF & _
" //tricky example" & @CRLF & _
" cout << "This // is // not a comment\n";" & @CRLF & _
"}"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)