using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(""(?=((?:[^""\\]+|\\[\s\S])*))\2""|'(?=((?:[^'\\]+|\\[\s\S])*))\3')|//.*|/\*(?=((?:[^*]+|\*(?!/))*))\4\*/";
string substitution = @"\1";
string input = @"/*My function
is great.*/
int j = 0//hello world
void foo(){
//tricky example
cout << ""This // is // not a comment\n"";
}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}