$re = '~("(?=((?:[^"\\\\]+|\\\\[\s\S])*))\2"|\'(?=((?:[^\'\\\\]+|\\\\[\s\S])*))\3\')|//.*|/\*(?=((?:[^*]+|\*(?!/))*))\4\*/~';
$str = '/*My function
is great.*/
int j = 0//hello world
void foo(){
//tricky example
cout << "This // is // not a comment\\n";
}';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;