#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<((?:(?!\/>)\S)+)(?:(?!\/>)[\s\S])*?>[\s\S]*?<\/\1\s*>"
Local $sString = "<style src="./x.css" /><style src="./z.css">cccccc</style>" & @CRLF & _
"<style src="./z.css"> </troll> </lol> </style >" & @CRLF & _
"<this> does" & @CRLF & _
" </this>" & @CRLF & _
"<does> work" & @CRLF & _
"</does >"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")