const regex = /<((?:(?!\/>)\S)+)(?:(?!\/>)[\s\S])*?>[\s\S]*?<\/\1\s*>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<((?:(?!\\\/>)\\S)+)(?:(?!\\\/>)[\\s\\S])*?>[\\s\\S]*?<\\\/\\1\\s*>', 'g')
const str = `<style src="./x.css" /><style src="./z.css">cccccc</style>
<style src="./z.css"> </troll> </lol> </style >
<this> does
</this>
<does> work
</does >`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}