$re = '/<((?:(?!\/>)\S)+)(?:(?!\/>)[\s\S])*?>[\s\S]*?<\/\1\s*>/';
$str = '<style src="./x.css" /><style src="./z.css">cccccc</style>
<style src="./z.css"> </troll> </lol> </style >
<this> does
</this>
<does> work
</does >';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);