import Foundation
let pattern = #"<((?:(?!\/>)\S)+)(?:(?!\/>)[\s\S])*?>[\s\S]*?<\/\1\s*>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<style src="./x.css" /><style src="./z.css">cccccc</style>
<style src="./z.css"> </troll> </lol> </style >
<this> does
</this>
<does> work
</does >
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)