const regex = /^(?!Andrea)(?:[\S\s](?!Andrea))*+$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!Andrea)(?:[\\S\\s](?!Andrea))*+$', '')
const str = `Example for Stack Overflow:
http://stackoverflow.com/questions/164414/how-to-inverse-match-with-regex
http://stackoverflow.com/a/38846455/1188377
This test string is NOT a match because it contains the text "Andrea". If it didn't contain that word, it would be a match.
For a variety of test cases, click the "Unit Tests" button on the left side of the page. It looks like a checkmark. Then, click the "play" icon above the test list.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}