import Foundation
let pattern = #"^(?!Andrea)(?:[\S\s](?!Andrea))*+$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Example for Stack Overflow:
http://stackoverflow.com/questions/164414/how-to-inverse-match-with-regex
http://stackoverflow.com/a/38846455/1188377
This test string is NOT a match because it contains the text "Andrea". If it didn't contain that word, it would be a match.
For a variety of test cases, click the "Unit Tests" button on the left side of the page. It looks like a checkmark. Then, click the "play" icon above the test list.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}