use strict;
my $str = 'Example for Stack Overflow:
http://stackoverflow.com/questions/164414/how-to-inverse-match-with-regex
http://stackoverflow.com/a/38846455/1188377
This test string is NOT a match because it contains the text "Andrea". If it didn\'t contain that word, it would be a match.
For a variety of test cases, click the "Unit Tests" button on the left side of the page. It looks like a checkmark. Then, click the "play" icon above the test list.';
my $regex = qr/^(?!Andrea)(?:[\S\s](?!Andrea))*+$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}