re = /^(?!Andrea)(?:[\S\s](?!Andrea))*+$/
str = 'Example for Stack Overflow:
http://stackoverflow.com/questions/164414/how-to-inverse-match-with-regex
http://stackoverflow.com/a/38846455/1188377
This test string is NOT a match because it contains the text "Andrea". If it didn\'t contain that word, it would be a match.
For a variety of test cases, click the "Unit Tests" button on the left side of the page. It looks like a checkmark. Then, click the "play" icon above the test list.'
# Print the match result
str.match(re) do |match|
puts match.to_s
end