package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[[:alnum:]éè ]+$`)
var str = `@test
test123é
abcdA
13465
éè 123test
_this-is
this_is`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}