const regex = /^[[:alnum:]éè ]+$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[[:alnum:]éè ]+$', 'mg')
const str = `@test
test123é
abcdA
13465
éè 123test
_this-is
this_is`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}