$re = '/^[[:alnum:]éè ]+$/m';
$str = '@test
test123é
abcdA
13465
éè 123test
_this-is
this_is';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);