using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([0-8])\1{2}[-](\d)\1{1}[-](\d)\1{3}";
string input = @"111-11-1111
123-11-1111
111-11-1112
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}