$re = '/([0-8])\1{2}[-](\d)\1{1}[-](\d)\1{3}/';
$str = '111-11-1111
123-11-1111
111-11-1112
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);