re = /([0-8])\1{2}[-](\d)\1{1}[-](\d)\1{3}/
str = '111-11-1111
123-11-1111
111-11-1112
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end