const regex = /([0-8])\1{2}[-](\d)\1{1}[-](\d)\1{3}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([0-8])\\1{2}[-](\\d)\\1{1}[-](\\d)\\1{3}', 'g')
const str = `111-11-1111
123-11-1111
111-11-1112
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}