using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\/[a-z-_\d\/]+[^\/^?^-^=^\.])$";
string input = @"/credentials/store/system/omAain/_/credentAial/b8931074-1cae-4ba1-8ff6-0cb03c358bc4A";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}