import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\/[a-z-_\\d\\/]+[^\\/^?^-^=^\\.])$";
final String string = "/credentials/store/system/omAain/_/credentAial/b8931074-1cae-4ba1-8ff6-0cb03c358bc4A";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}