re = /^(\/[a-z-_\d\/]+[^\/^?^-^=^\.])$/
str = '/credentials/store/system/omAain/_/credentAial/b8931074-1cae-4ba1-8ff6-0cb03c358bc4A'
# Print the match result
str.match(re) do |match|
puts match.to_s
end