package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\/[a-z-_\d\/]+[^\/^?^-^=^\.])$`)
var str = `/credentials/store/system/omAain/_/credentAial/b8931074-1cae-4ba1-8ff6-0cb03c358bc4A`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}