#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=[^Q\d]*(?=\d))(?:(?<!Q)|(?<=[A-Z]{2}Q)|\D*\d+\.\d{2})[^Q\d]*([1-9]\d*\.\d{2})(?!END\b)"
Local $sString = "ABC WS YMQ234.03WS TOY234.03USD468.06END" & @CRLF & _
"FUR BB LAB Q10.00 199.00USD209.00END" & @CRLF & _
"YAS DG TYY Q AWSMSN11.32 2503.08LD VET Q JKLOLE11.32 2503.08USD5028.80END" & @CRLF & _
"PPP VP LAP Q10.00 M342.41EE SFD Q10.00 282.24USD644.65END" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")