import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=[^Q\\d]*(?=\\d))(?:(?<!Q)|(?<=[A-Z]{2}Q)|\\D*\\d+\\.\\d{2})[^Q\\d]*([1-9]\\d*\\.\\d{2})(?!END\\b)";
final String string = "ABC WS YMQ234.03WS TOY234.03USD468.06END\n"
+ "FUR BB LAB Q10.00 199.00USD209.00END\n"
+ "YAS DG TYY Q AWSMSN11.32 2503.08LD VET Q JKLOLE11.32 2503.08USD5028.80END\n"
+ "PPP VP LAP Q10.00 M342.41EE SFD Q10.00 282.24USD644.65END\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}