$re = '/(?=[^Q\d]*(?=\d))(?:(?<!Q)|(?<=[A-Z]{2}Q)|\D*\d+\.\d{2})[^Q\d]*([1-9]\d*\.\d{2})(?!END\b)/m';
$str = 'ABC WS YMQ234.03WS TOY234.03USD468.06END
FUR BB LAB Q10.00 199.00USD209.00END
YAS DG TYY Q AWSMSN11.32 2503.08LD VET Q JKLOLE11.32 2503.08USD5028.80END
PPP VP LAP Q10.00 M342.41EE SFD Q10.00 282.24USD644.65END
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);