import re
regex = re.compile(r"(?=[^Q\d]*(?=\d))(?:(?<!Q)|(?<=[A-Z]{2}Q)|\D*\d+\.\d{2})[^Q\d]*([1-9]\d*\.\d{2})(?!END\b)", flags=re.MULTILINE)
test_str = ("ABC WS YMQ234.03WS TOY234.03USD468.06END\n"
"FUR BB LAB Q10.00 199.00USD209.00END\n"
"YAS DG TYY Q AWSMSN11.32 2503.08LD VET Q JKLOLE11.32 2503.08USD5028.80END\n"
"PPP VP LAP Q10.00 M342.41EE SFD Q10.00 282.24USD644.65END\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")