#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?!ISSN).)*(?![^()]*\))(\d+-\d+)$"
Local $sString = "Journal Name, Vol. 20, No. 2; p. 15" & @CRLF & _
"Journal Name, Vol. 20, No. 2: Human Name (1990-2010); p. 15" & @CRLF & _
"Journal Name, Vol. 20, No. 2: Human Name (1990-2010); pp. 15-20" & @CRLF & _
"Journal Name, Vol. 20, No. 2: Human Name (1990-2010); pp. 15-" & @CRLF & _
"Journal Name, Vol. 20, No. 2; 20-25" & @CRLF & _
"Journal Name, Vol. 20, No. 2; ISSN: 1234-1234 (Print); 20-25" & @CRLF & _
"Journal Name, Vol. 20, No. 2; 20-25; ISSN: 1234-1234 (Print)" & @CRLF & _
"Journal Name, Vol. 20, No. 2; ISSN: 1234-1234 (Print); ISSN: 1234-1234 (Online); 20-25" & @CRLF & _
"Journal Name, Vol. 20, No. 2; ISSN 1234-1234 (Print); ISSN 1234-1234 (Online); 20-25"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")