const regex = new RegExp('^((?!ISSN).)*(?![^()]*\\))(\\d+-\\d+)$', 'gm')
const str = `Journal Name, Vol. 20, No. 2; p. 15
Journal Name, Vol. 20, No. 2: Human Name (1990-2010); p. 15
Journal Name, Vol. 20, No. 2: Human Name (1990-2010); pp. 15-20
Journal Name, Vol. 20, No. 2: Human Name (1990-2010); pp. 15-
Journal Name, Vol. 20, No. 2; 20-25
Journal Name, Vol. 20, No. 2; ISSN: 1234-1234 (Print); 20-25
Journal Name, Vol. 20, No. 2; 20-25; ISSN: 1234-1234 (Print)
Journal Name, Vol. 20, No. 2; ISSN: 1234-1234 (Print); ISSN: 1234-1234 (Online); 20-25
Journal Name, Vol. 20, No. 2; ISSN 1234-1234 (Print); ISSN 1234-1234 (Online); 20-25`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}