re = /^((?!ISSN).)*(?![^()]*\))(\d+-\d+)$/m
str = 'Journal Name, Vol. 20, No. 2; p. 15
Journal Name, Vol. 20, No. 2: Human Name (1990-2010); p. 15
Journal Name, Vol. 20, No. 2: Human Name (1990-2010); pp. 15-20
Journal Name, Vol. 20, No. 2: Human Name (1990-2010); pp. 15-
Journal Name, Vol. 20, No. 2; 20-25
Journal Name, Vol. 20, No. 2; ISSN: 1234-1234 (Print); 20-25
Journal Name, Vol. 20, No. 2; 20-25; ISSN: 1234-1234 (Print)
Journal Name, Vol. 20, No. 2; ISSN: 1234-1234 (Print); ISSN: 1234-1234 (Online); 20-25
Journal Name, Vol. 20, No. 2; ISSN 1234-1234 (Print); ISSN 1234-1234 (Online); 20-25'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end