using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?!ISSN).)*(?![^()]*\))(\d+-\d+)$";
string input = @"Journal Name, Vol. 20, No. 2; p. 15
Journal Name, Vol. 20, No. 2: Human Name (1990-2010); p. 15
Journal Name, Vol. 20, No. 2: Human Name (1990-2010); pp. 15-20
Journal Name, Vol. 20, No. 2: Human Name (1990-2010); pp. 15-
Journal Name, Vol. 20, No. 2; 20-25
Journal Name, Vol. 20, No. 2; ISSN: 1234-1234 (Print); 20-25
Journal Name, Vol. 20, No. 2; 20-25; ISSN: 1234-1234 (Print)
Journal Name, Vol. 20, No. 2; ISSN: 1234-1234 (Print); ISSN: 1234-1234 (Online); 20-25
Journal Name, Vol. 20, No. 2; ISSN 1234-1234 (Print); ISSN 1234-1234 (Online); 20-25";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}