const regex = /(?<class>^(?<fully_qualified_class_name>(?<deliniator>(?<!\\)\\(?!\\)(?=(?P>fully_qualified_class_name))){0,1}[A-z_][\w]*)(?=::(?P>method)|$)|^(?<namespace>^(?P>fully_qualified_class_name)*)(?P>deliniator)(?P>fully_qualified_class_name)(?=::(?P>method)|$))(?<scope_resolution_operator>::(?=(?P>method)(?!$)))?(?<method>(?<=::)(?<operation>(?<mutator>[sS]et(?=[A-Z0-1_]|$))|(?<accessor>[gG]et(?=[A-Z0-1_]|$))|(?<condition>[iI]s(?=[A-Z0-1_]|$)|[hH]as(?=[A-Z0-1_]|$)))?_?(?<target>(?<=\w)\w*)|[A-z_]\w*)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<class>^(?<fully_qualified_class_name>(?<deliniator>(?<!\\\\)\\\\(?!\\\\)(?=(?P>fully_qualified_class_name))){0,1}[A-z_][\\w]*)(?=::(?P>method)|$)|^(?<namespace>^(?P>fully_qualified_class_name)*)(?P>deliniator)(?P>fully_qualified_class_name)(?=::(?P>method)|$))(?<scope_resolution_operator>::(?=(?P>method)(?!$)))?(?<method>(?<=::)(?<operation>(?<mutator>[sS]et(?=[A-Z0-1_]|$))|(?<accessor>[gG]et(?=[A-Z0-1_]|$))|(?<condition>[iI]s(?=[A-Z0-1_]|$)|[hH]as(?=[A-Z0-1_]|$)))?_?(?<target>(?<=\\w)\\w*)|[A-z_]\\w*)?$', 'gm')
const str = `/Class and Namespace Capture
Nam_e
\\_Nam_e
Nam_e\\Spac_e
/Class Method and Namespace Capture
/With Operation and Target
Nam_e::set_Singular
\\Nam_e\\Spac_e::isSingular
\\Nam_e\\Spac_e::
/Class Method and Deep Namespace Capture
/Without Operation and Target
Nam_e\\Spac_e\\Accessible\\Caller\\Value::setsingular
\\Nam_e\\Spac_e\\Accessible\\Caller\\Value::singular
/Class Method and Deep Namespace Capture
/With Mutator Operation and Target
Nam_e\\Spac_e\\Accessible\\Caller\\Value::setSingular
/Class Method and Deep Namespace Capture
/With Accessor Operation and Target
Nam_e\\Spac_e\\Accessible\\Caller\\Value::get_singular
/Class Method and Deep Namespace Capture
/With Conditional Operation and Target
\\Nam_e\\Spac_e\\Accessible\\Caller\\Value::isSingular
Nam_e\\Spac_e\\Accessible\\Caller\\Value::has_Singular`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}