import Foundation
let pattern = #"(?<class>^(?<fully_qualified_class_name>(?<deliniator>(?<!\\)\\(?!\\)(?=(?P>fully_qualified_class_name))){0,1}[A-z_][\w]*)(?=::(?P>method)|$)|^(?<namespace>^(?P>fully_qualified_class_name)*)(?P>deliniator)(?P>fully_qualified_class_name)(?=::(?P>method)|$))(?<scope_resolution_operator>::(?=(?P>method)(?!$)))?(?<method>(?<=::)(?<operation>(?<mutator>[sS]et(?=[A-Z0-1_]|$))|(?<accessor>[gG]et(?=[A-Z0-1_]|$))|(?<condition>[iI]s(?=[A-Z0-1_]|$)|[hH]as(?=[A-Z0-1_]|$)))?_?(?<target>(?<=\w)\w*)|[A-z_]\w*)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/Class and Namespace Capture
Nam_e
\_Nam_e
Nam_e\Spac_e
/Class Method and Namespace Capture
/With Operation and Target
Nam_e::set_Singular
\Nam_e\Spac_e::isSingular
\Nam_e\Spac_e::
/Class Method and Deep Namespace Capture
/Without Operation and Target
Nam_e\Spac_e\Accessible\Caller\Value::setsingular
\Nam_e\Spac_e\Accessible\Caller\Value::singular
/Class Method and Deep Namespace Capture
/With Mutator Operation and Target
Nam_e\Spac_e\Accessible\Caller\Value::setSingular
/Class Method and Deep Namespace Capture
/With Accessor Operation and Target
Nam_e\Spac_e\Accessible\Caller\Value::get_singular
/Class Method and Deep Namespace Capture
/With Conditional Operation and Target
\Nam_e\Spac_e\Accessible\Caller\Value::isSingular
Nam_e\Spac_e\Accessible\Caller\Value::has_Singular
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)